Getting Scrapy installed on OSX proved to be a pain. One of the requirements for Scrapy is LXML, requiring a C compiler. Even with XCode installed, I was missing one thing. For Python Package Index  (pip) packages to successfully compile when installing, one more thing needs to be installed, the command line tool for XCode. This can be installed using the command:

xcode-select --install

Once installed, installing Scrapy requires little more than using the command:

pip install scrapy